


Operator - a word or symbol such as AND or OR used in a query, which ISYS 
treats differently from the rest of the query text



Synonyms - words which have similar meaning



Synonym expansion setting - a setting in the Preferences Window which 
tells ISYS whether to automatically search for the words entered in synonym 
rings.



Synonym rings - ISYS stores a synonym as a series of words in a ring. If any
word in a ring is entered in a query, then any occurrences of the other words 
in the ring are also found by the query.



Document list - The document list shows you the documents which match 
your query. 



Hit List - The hit list shows you each of the words in your query ISYS found, 
and the total number of matches for that word. 



Paragraph - For word processor files, a paragraph is considered to end at 
the next hard return. For ASCII files, a paragraph is up to the next blank line 
(i.e. two carriage returns in a row).



Significant characters - characters which are included in the ISYS 
database and are treated as an important part of any word in which they 
appear. E.g if the hyphen is defined as significant, then "nucleic-acid" is 
indexed as "nucleic-acid"



Insignificant characters - characters which are not included in the 
database and treated as if non-existent. E.g if the hyphen is defined as 
insignificant, then "nucleic-acid" is indexed as "nucleicacid".



Punctuation characters - characters which are neither significant or 
insignificant and are treated as the end of a word and the start of another. 
E.g if the hyphen is a punctuation character, then "nucleic-acid" is indexed as
two words - "nucleic" and "acid".



Word tense conflation - conflation allows ISYS to find different tenses of a 
word, e.g. "build", "built", "building".



Command-based query - a query which is typed directly into ISYS using 
the built in command language.



Saved query list - a list of commonly run queries which are stored in a list 
for easy recall.



Preferences - a number of settings which enable you to customize ISYS 
operation.



Hits - words which match the query you have entered



Hit in context -    a word which matches the query you entered displayed 
with the words which occur around it (in its "context").



Filters - a way to make ISYS display only certain documents it finds to you in
the document list.



Query Results - the documents and words which are found by your query, 
displayed to you as the document and hit lists in the ISYS Query window.



File Path - the MS-DOS directory path to the document



File Name - the MS-DOS file name of the document



Annotations - extra information you can add to a document, which can then
be viewed or run by clicking on the symbol which is inserted into the text in 
IQ Browse.



Text note - a text annotation. When you click on the symbol in IQ Browse 
you see the text in a window.



Graphic Image - a picture annotation. When you click on the symbol in IQ 
Browse you see the graphic in a window.



Hyperactivity - an annotation which is a program that is activated when 
you click it.



Embedded Queries - attaching or linking a query allows you to store a 
query in the ISYS browse screen that may be relevant to the text displayed. 



Hyperlinks - allow you to create links between documents that you consider
to be related.



Query - a query is the process of telling ISYS what you want to find.



Document - documents are the files on your computer or in your network 
which contain information that is included in the ISYS database. Documents 
may be almost any type of file (e.g. spreadsheet or database), but are 
usually word processor files or plain text.



Hypertext query - the query is first stripped of any common words or 
operators, and word tense conflation is also turned on for each remaining 
word before being passed to ISYS to run.



Exact query - the query is passed to ISYS as is, with no prior processing for 
operators or common words, etc.



Common Word - a word that is defined as commonly occurring in your 
documents, excluded to save disk space and unnecessary matches.



Label - the words a paragraph starts with



Document Titles - a specified line in each document can be defined to be 
the title of the document.



Database - ISYS stores the index to your documents in a database. Queries 
are run against the database rather than searching your disk for documents.



Rules - Rules tell ISYS which documents to include in or exclude from your 
database



Exclude rule - a rule that tells ISYS not to include the document in the 
database.



Reverse chronological order - from newest to oldest



Chronological order - from oldest to newest



Ventura Publisher - a desktop publishing program which inserts special 
markers into documents for the control of formatting. If alerted to their 
presence, ISYS knows how to handle with the markers.



Dos Environment Variable - a special command used in DOS with the SET 
= command. See your DOS manual for further detail.



Document format - the type of file the document is, determined by its 
application, e.g. Word for Windows .DOC document, dBase .DBF database, 
etc.



Catalog - a catalog of databases provides the user with an easy way to 
select a database for querying, rather than navigating the directory tree to 
locate where the database resides.



Index Files - An ISYS database is contained within the index and 
configuration files i.e., ISYS.IXA, ISYS.IXB, ISYS.IXC and ISYS.CFG.    Where 
these files reside is known as the database root node.



Fuzzy precompensation - ISYS uses sophisticated heuristical, algorithmic 
and statistical means to determine which words are likely errors of other 
words.    When the option is active ISYS queries will automatically and 
transparently retrieve words that it considers may be OCR scanning errors or 
other typographical errors.
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ISYS Query window
Make queries from this window. It displays the documents which satisfy your 
query. 
Along the top, under the menu bar, are a strip of buttons for the most 
commonly used functions. As you move the pointer over these buttons, ISYS 
displays a short description in the balloon help and also on the status line at 
the bottom left of the window.
The lower part of the window is divided in two. The left section is the 
document list, and the right section is the hit list. You can adjust the space 
given to each of the lists by clicking and dragging on the dividing bar.
See Also:
Menu-assisted query
Command-based query
Plain-English query
Customizable Toolbars



Customizable Toolbars
ISYS uses a similar toolbar configuration scheme as Word for Windows, 
grouping the buttons into categories.    From the Option Menu select either 
Toolbar Main for the Query window toolbar, or Toolbar Browse for the browse 
window toolbar.
A palette of tools is provided that lists almost every option available under 
the menus, and you are able to choose which buttons will appear on the 
toolbar, and in which position.
Once the toolbar configuration window is open you can:
· Drag a button from one place to another on the toolbar
· Drag tools from the palette on to the toolbar
· Drag tools off the toolbar (to remove them)
Choose the OK button to save your changes, or use Cancel to cancel any 
changes and exit from the window, or the Reset option to reset the toolbar to
the default selections.



Front Page

The Front Page Document may contain, for example, a table of contents or 
information which has links to other relevant documents.
To use the front page, just click on any of the annotation links and ISYS will 
take you directly to the linked document, image or other annotation.
To set up a Front Page document, use the Hyperlink annotation feature.
See Also:
IQ Browse Window
Annotations



Selecting a database - by directory
You can to work with a different database by choosing the DATABASE button 
from the Query Window.    This will take you to one of two forms of the Select 
Database Window.
If you do not have up a database catalog established, you will be    disk 
directory from which to select your database.    If an ISYS database is present 
in a directory, its name will be shown in the Selected Database box at the top
of the window. 
When the window is showing the database you want to work with, choose the
OK button.
The Add to Catalog button will be active if this option has been made 
available to you by your database administrator.    Choose this button if you 
wish to add the database to the catalog.



Selecting a database via the Catalog
You can to work with a different database by choosing the DATABASE button 
from the Query Window.    This will take you to one of two forms of the Select 
Database Window.
If you have an established database catalog, you will be able to select a 
database by name.    
The radio buttons at the bottom of the Select database window will be active
if your database administrator has made this option available to you, 
allowing you to switch between the Catalog and the Disk Directory.    The 
Multiple Select check box, will if checked, allow you to mark a number of 
databases in the catalog for dynamic linking.
Select the database you want to work with, then choose the OK button.



Menu-assisted query

To make a menu assisted query choose the Menu-assisted query button, or 
select the Menu-Assisted item from the Tools menu, or press CTRL-M on your 
keyboard.
Enter the word or phrase you want to find into the "Find all documents that 
contain" field. Then select the button for the operator you want, and then 
enter the second word or phrase, and so on.
When you've finished, you are returned to the ISYS Query window with all the
matching documents displayed.

Your database may have been configured with the Fuzzy precompensation 
option enabled.    For example, you may search for duck and ISYS will also 
retrieve cluck, as it is possible that the d was slightly broken and mis-
scanned as a cl.

See Also:

Menu-assisted Operator reference

Command-Based query



Menu-assisted operator reference
The operators in the Menu Assisted window are:

AND which also contain
Use the And operator to locate documents which contain both of the entered 
words or phrases anywhere in the text of the document.

OR which contain
Use the Or operator to locate documents which contain any one of the 
entered words or phrases.

But do NOT contain
Use the Not operator to locate documents which contain the first word or 
phrase, but not the second one.

Within a paragraph of
Use the Within a Paragraph operator to locate documents which not only 
contain both words or phrases, but also contain these words within a 
paragraph either side of each other.

In the same paragraph as
Use the In the same paragraph operator to locate documents which not only 
contain both words or phrases entered, but contain the words in the same 
paragraph. This is an even more specific search than the Within a paragraph 
and the And operators.

Within 10 words of
Use the Within 10 words operator to locate documents which both words or 
phrases appear in the same paragraph and within ten words of one another.

Followed anywhere by
Use the Followed by operator to locate documents in which the first word or 
phrase is followed anywhere by the second. The second word or phrase can 
be anywhere in document, as long as it is after the first one.

IN the paragraph labelled
Use the In the paragraph labelled operator to locate documents where the 
first word occurs anywhere in a paragraph which starts with the second 
word.
See Also:
Command-based query
Command-based operator reference



Command-based query

To make a command-based query choose the Command-based query button,
or select the Command-based item from the Tools menu, or press CTRL-C on 
your keyboard. The command-based query uses the ISYS command 
language.
Enter the command-based query and into the entry box and click on the OK 
button. The list box button on the right of the entry box allows you to select a
command entered previously during this ISYS session.
When you've finished, you are returned to the ISYS Query window with all the
matching documents displayed.
Your database may have been configured with the Fuzzy precompensation 
option enabled.    For example, you may search for duck and ISYS will also 
retrieve cluck, as it is possible that the d was slightly broken and mis-
scanned as a cl.
See Also:
Menu-assisted query
Command-based operator reference
Special symbols



Command-based operator reference
The following is a list of the operators you can use in your queries. Although 
they are written here in all capitals, it is not necessary to enter them as such.

AND
The AND operator is used to locate documents which contain both of the 
entered words or phrases anywhere in the text of the document.

OR
The OR operator is used to locate documents which contain any one of the 
entered words or phrases.

NOT
The NOT operator is used to locate documents which contain the first word or
phrase, but not the second.

XOR
The XOR operator is used to locate documents which contain either the first 
word or phrase, or the second, but not both.

EXCEPT
The EXCEPT operator is used to locate documents in which the first word or 
phrase appears, but only if the second term or phrase is not in the same 
paragraph as the first. This is a more specific version of NOT.

...
The FAR FOLLOW operator is used to locate documents where the first word 
or phrase is subsequently followed by the second. That is, both words or 
phrases occur in the document, but the second one must occur after the 
first.

..
The CLOSE FOLLOW operator is used to locate documents where the first 
word or phrase is followed by the second word or phrase in pairs.

\x,y\
The IN PARAS operator is used to locate documents where both words or 
phrases occur within the specified number of paragraphs of each other. 
You can use the form "\\" to specify "within a paragraph of". You can also 
specify negative paragraph numbers.
The default for x is 1, and y defaults to -x.

/x,y/ or W/n
The NEAR BY operator is used to locate documents where both words or 
phrases appear in the same paragraph, within the number of words specified
by x and y, or n (in the second case). 
You can use the form "//" to specify "in the same paragraph".
The default for y is the end of the paragraph, and the default for x is -y (i.e. 



the beginning of the paragraph). You can also specify negative ranges.
IN

The IN operator is used to locate documents which contains the first word or 
phrase in a paragraph that is labelled with the second word or phrase.

LABEL
The LABEL operator is used to find documents which contain a paragraph 
that is labelled with the word or phrase.

TO
The TO operator specifies an alphabetic or numeric range. The TO operator 
can be used to search for dates if they are expressed in YYMMDD format.

AFTER
For use in conjunction with the Intelligent Date Handling database 
configuraton option, this operator allows you to search for any documents 
containing dates After a specific date.

BEFORE

For use in conjunction with the Intelligent Date Handling database 
configuration option, this operator allows you to search for any documents 
containing dates Before a specific date.

See Also:

Menu-Assisted Operator Reference

Special Symbols



Plain-English query

To make a Plain English query, either choose the Plain English Query button, 
select Plain English Query from the Tools Menu or press CTRL-E on your 
keyboard.
Plain English Queries let you type in exactly what you need to know in plain, 
everyday English, without the complication of trying to formulate a query 
command or make the conceptual transition into operators and search 
terms.
For example, if you want to find what's happening with printers in OS/2, you 
could simply type:
        Tell me what's happening with printers in OS/2
See Also:
Menu-assisted query
Command-Based query



Word Wheel

To find out whether a word has been indexed, click on the Word Wheel icon 
which you will see located at the top of the Menu-assisted window or to the 
right of the Command-Based Query window, or in the bottom right of the 
Plain-English query window.
As you type characters into the box at the top of the word wheel window, it 
will show you a list of words that either:
· start with the same characters as the ones you've typed in (if you have the

Starts With radio button selected), or
· sound the same as the word you've typed in (if you have the Sounds 
like radio button selected)
To include a word from the wheel in your query single-click on the word, then 
choose OK, to add the word to the query line and close the Word Wheel 
window.      Or double-click on the word and it will be ORed to your query and 
the Word Wheel window will remain open.



Special symbols * ! ~ +
There are a number of special symbols which change the meaning of the 
commands entered in a query. They are:

* or !
The "*" or "!" symbols tell ISYS to find any number of significant characters. 
They are similar to the DOS wildcard character. The wildcard * can also be 
used at the beginning of a word, however only one wildcard can be used per 
word.    Note that the amount of time to complete the query will increase as 
the position of the * moves toward the left.

~
The "~" symbol tells ISYS to apply conflation to a word.
By default conflation is set to off in the Preferences section of ISYS Query.    
Using this symbol in a query will turn it on for this word.    If you change your 
preference so that conflation is always turned on, use this symbol to turn 
conflation off.
You can also use the conflation operator at the beginning of a word, or at 
both ends of word.

+
The "+" symbol is the toggle switch for the synonym expansion setting.    
When you enter a word into a query that is defined in a synonym ring, 
depending on this operator and the automatic synonym setting in the 
Preferences window, ISYS will also search for all the other words in the ring.
By default, synonyms are turned on in the Preferences section of ISYS Query. 
If synonym expansion is on, using this symbol in a query will turn it off just 
for this word, and vice versa.
See Also:
Synonyms
Command-based query
Command-based operator reference



Query by Concept

To make a Query-by-concept choose the Query-by-concept button, select the 
Query-by-concept item from the Tools menu, or press CTRL-Q on your 
keyboard. The concepts are organized in a hierarchical "tree" format, i.e. 
concepts contain sub-concepts which may in turn contain further sub-
concepts.
The concepts which contain queries you can run are indicated by green tabs 
on the folder. Concepts which contain sub-concepts have a small plus "+" 
sign in the folder.
To see the sub-concepts in a concept, double-click on the concept's folder. If 
you have a large number of concepts, you can search for the one you want 
using the Find button or Tree - Find and Tree - Find Next menu items.
To run a concept, select it (with a single-click), and then click on the Go 
button. You are shown another window where you may add additional criteria
to the query. Click on OK to run the query.
When it's finished, you are returned to the ISYS Query window with all the 
matching documents displayed.
Query-by-concept will not work unless a concept tree has been setup for the 
database. For information on setting up a concept tree, see the help for 
"concept tree" in ISYS Utilities help.
See Also:
Command-based query



Saved query list

Make a query from the Saved Query List by choosing the Saved Query 
button, or the Save Query List item from the Tools menu, or by pressing 
CTRL-S on your keyboard. To run a query, click on the one you want, then 
click on the OK button.
When it's finished, you are returned to the ISYS Query window with all the 
matching documents displayed.

Adding a query to the list
To add a query to the saved list, click on the Add button in the Saved Query 
List window. The Add New Query window is shown.
Type the name for the query in the Query Name text box, and then type the 
ISYS command-based query to run in the Query Command text box. For more
information about the ISYS query commands, please see the Command-
based operator reference.

Adding    the last query from another query type

When in one of the other query modes, you can add the query last run to the
saved list from the ISYS Query window. To do this, select the Tools menu, 
then the Add To Saved Queries item. Alternatively, you can press CTRL-A on 
your keyboard. The current query is added to the saved query list.

See Also:

Menu-assisted query

Command-based query

Query By Concept



Querying within the query results 

You can make a query within the current query's results, or the previous 
query's results. That is, the query will only search the documents which were
found in the results of the current query (or the query before that).
Choose the appropriate button, or from the Tools menu or select Query 
Within Current Results or Query Within Previous Results.    You will not be able
to select the Query Within Previous Results until you make at least one query
within the current results.
ISYS uses the query method last used to run the new query. In effect, this 
new query is ANDed onto the end of your previous query. The earlier query is
not run again, however, so the search time is less than running the whole 
new query.
Note - if you have performed a series of queries within current results, and 
opt to save the last query in the saved query library, ISYS will correctly 
formulate a query that represents the end result of all your queries within 
current and previous queries.



Synonyms
Synonyms are grouped in synonym "rings". Whether ISYS finds synonyms or 
not is controlled by both the special synonym command-line operator "+", 
and the automatic synonym expansion setting in ISYS Preferences.
To maintain your synonym rings, select the Options menu and then the 
Synonyms item. The Synonym screen is divided vertically in half. On the left 
is the list of rings. On the right are the entries in the currently selected ring. 
To add an entirely new ring, click on the left hand Add button. To add a new 
entry to a ring, select the ring you want to add to, then click on the right 
hand add button.

Wildcards & Conflation in synonyms
The truncation or wildcard * operator can be used in synonym rings. If you 
have a ring entry such as price*, and your search term is price, then ISYS will
find all the words beginning with price.
The conflation ~ operator can also be used in synonym rings.    If you have a 
ring entry such as management~, and your search term is management, 
then ISYS will find all conflation related words.

Passive Synonyms
It is possible to set up synonyms that will expand in one direction only.    
These synonyms are known as one-way or passive synonym rings. 
A passive entry is created by simply postfixing the ring entry with a hyphen  
  .    For example, if the ring entries were: 
Dog, Canine, Pooch, Greyhound-, Terrier-, Labrador- 
a query for dog would search for all entries in the ring, but a query for 
greyhound would only search on greyhound and no other entry in the ring.



Preferences

ISYS has a number of preferences which enable you to customize its 
operation. To change the preferences, click on the preferences button, or 
select the Options menu and Preferences item.
The Preferences window displays in tab form the following groups of 
preferences:

Queries
· Activate the automatic synonyms expansion facility;    
· Activate automatic word tense conflation; 

There are special symbols for reversing these two settings for the current 
word in a query.

· Allow concepts to be refined with AND or NOT.    This allows the user to 
refine concept queries by adding additional query syntax; 

· Display popup section list for IN operator in Menu Assisted queries.    
This is useful for informing the user of the existence of any Sections which 
have been established for the database; 
· Have ISYS start a second instance of the Query program for nested 
queries.

Context of found hits
This controls how much text you see when you choose to display the hits in 
context in the ISYS Query window. You can choose to see a certain number of
lines on either side of the hit by selecting the "Lines either side" radio button,
and typing the number of lines into the box alongside. You could alternatively
choose to see the entire paragraph the hits are in by selecting the "Entire 
paragraph" radio button.

Documents 
· Open your document browse screen at the top of the document or at the 

occurrence of the first hit; 
· Automatically browse a document if only one document results from 
the executed query. 
· Set Font Selections for the document browse window and the hit color . 
To change the display font, choose the Set Font button. ISYS shows you the 
Font window. 
· ISYS only allows you to choose from the fixed-pitch fonts on your 
system. If you want to display documents which contain high ASCII 
characters (i.e. ASCII characters in the range of 128 - 255, e.g. line drawing 
characters), you should select a font that supports those characters, for 
instance the Terminal font. If this font is not on your machine, you can add it 
from the Windows control panel. 

Gather & Print 



This set of options is for controlling the information that is displayed at the 
top of any selected text that is gathered, printed or e-mailed.    These options
are:    
· Current page number (if document has pages) 
· Document name 
· Document date 
· ISYS database name 
· Today's date 
· Query used to find the document 

Printer Options 
These options indicate to ISYS which defaults should be used when printing 
information: 
· The word processor should be used to print documents where possible; 
· Selected text should be printed in double-spaced format. 

General Options 
· Have ISYS beep when an error is made; 
· Always close the browsed document prior to activating the word 
processor application; 
· Font selection for use in Plain-English Queries; 
· Word processor activation options.    This option will display the 
following window.    Normally you would leave ISYS to work out the correct 
application to launch when activating a document.    However, you can if you 
wish tailor this function in either of two ways:

Use Windows REG.DAT associations, which means that ISYS will follow 
whatever associations you have set up under File Manager, or 
Use a nominated application, passing to the application the 
appropriate DDE commands.    In this instance ISYS is acting in a DDE 
CLIENT role.    You will need to refer to the applications technical 
documentation for the correct syntax of the commands to use. 

Note - the two radio buttons at the top of the dialog box.    By choosing the 
appropriate button you can declare different activation options for opening or
printing the document. 
See Also:
Synonyms
Special Symbols
Sections
Menu Assisted Query 



Selecting a printer 
You can select which printer ISYS prints documents on if you have two or 
more printers available for use.    Usually, you print to the default Windows 
printer.    Select the Options menu, then the Printer item.    Select the radio 
button for either the Default printer, or a Specific printer. 
The Options button displays the same printer options window as is displayed 
from the Windows printer control panel, and varies according to the printer 
driver you have installed.    For more information about installing, setting up, 
and selecting printers in Windows, see your Windows manual.



Filters

The filters allow you to configure ISYS to only display particular documents in
the document list.
To filter the query results, click on the Filter button. Alternatively, select the 
File menu, and then the Filter Results item, or you can press CTRL-F on your 
keyboard. 
The Filter window is displayed to you. The drop down boxes on the fields in 
the Filter window allow you to choose from earlier filter settings.
See Also:
Filter options reference
ISYS Query Window



Filter options reference
File path contains

Type the string that the file path must contain for the document to be 
displayed. You can enter multiple entries delimited by a semicolon.

File path omits
Type the string that the file path must not contain for the document to be 
displayed. You can enter multiple entries delimited by a semicolon.

File name like
Type the DOS file specification which documents must match to be displayed.
You can also enter multiple entries delimited by a semicolon.
For more information on DOS file naming conventions, and wildcards, see 
your DOS and Windows manuals.

File name unlike
Type the DOS file specification which documents must not match to be 
displayed. You can also enter multiple entries delimited by a semicolon.
For more information on DOS file naming conventions, and wildcards, see 
your DOS and Windows manuals.

File date from; To
To only include files between certain dates, enter the dates into the File Date 
From and To fields. The dates are inclusive.

Apply to the current results; Apply to the results of future queries
You can choose to apply the filter to just this current document list, or to all 
future query results, or to both, with the Apply to the current results, and the 
Apply to the results of future queries check boxes. 
See Also:
Filters



Sorting results

You can change the way the document list is sorted. Click on the Sort button.
Alternatively, select the File menu, then the Sort Results item or press CTRL-
O on your keyboard. 
Choosing another sort order other than the default database order may 
significantly affect performance if a large number of documents are found by
your query.
The Sort Options window has the following options:

Default database order
Sorts by the order the document is found in the database, which is reverse 
chronological (i.e. from the newest to the oldest). 

Number of hits
The documents are listed with the document with the greatest number of 
hits first.

Size of document
The documents are listed from the largest document to the smallest 
document.

Full path name
The document path names are sorted alphabetically. Documents in the same 
directory are sorted alphabetically.

File extension
The documents are sorted alphabetically by the three letter extension. 
Documents with the same extension are sorted in the order they appear in 
the database.

File name
The documents are sorted alphabetically according to the file name. Paths 
are not sorted.

File date
Documents are listed from the newest time and date to the oldest file time 
and date.

Relevancy
Will sort your documents by the density of hits i.e. those documents whose 
number of hits to file size ratio is highest will appear first.

Make default
Makes the selected sorting method the default method for future queries.
See Also:
ISYS Query Window



IQ Browse window
The IQ Browse window is ISYSs internal document viewer. To view a 
document with IQ Browse, double-click on the document you want in the 
document list in the ISYS Query window.

The file arrow buttons allow to view the previous and next file
The hit arrow buttons allow you to view    the previous and next hit
To the left of these buttons is a small button which looks like a 

Windows Control menu box. This button is a simple, single-click, method of 
exiting the IQ Browse window.

Selected text operations

As well as viewing documents, you can highlight text and do a number of 
things with it, using this group of buttons you can:

· Copy it to the clipboard
· Gather it to the Windows Notepad
· E-mail it to someone with your e-mail application
· Print it
· Send to your fax interface
· Run another query

Annotations

You can also insert and view annotations. Annotations can be:
· Text notes

· Graphic images
· Hyperactivities 
· Embedded Queries
· Hypertext link
To insert an annotation, click on the appropriate annotation button, or from 
the Edit menu select Annotate and the annotation action you wish to perform
or Ctrl-T, Ctrl-G, Ctrl-H, Ctrl-Q or Ctrl-L.
To view or run an annotation, simply click on the symbol which appears in 
the text.

Annotation Directory

If annotations have been created for the browsed document, then the 
Annotation Directory button will be active.    To see a Directory of the 
Annotations choose this button or use the Next/Previous Annotation option 



from the Edit menu to move between annotations.    The directory will allow 
you to jump to or open the selected annotation, print one or all of the text 
annotations or delete the selected annotation.

Drag-Drop Capability

ISYS has the ability to act as a drag-drop server and/or client. You can click 
on a document name in the document list, and drag it into any another 
application that functions as a drag-drop client.    This button is available in 
the IQ Browse window toolbar for initiating drag-drops from the Browse 
window, for example when linking documents.
See Also:
Annotations



Annotations

Inserting annotations
To insert an annotation, click on the appropriate annotation button, or from 
the Edit menu select Annotate and the annotation action you wish to perform
or Ctrl-T, Ctrl-G, Ctrl-H, Ctrl-Q or Ctrl-L.

Hyperlink annotations
There are two methods for creating hyperlinks between documents.    This 
first method requires that you have open all documents (in browse mode) 
that you wish to create links between.

Conduct your query or queries to locate the documents which you 
intend to link.    As you find the relevant documents, open each one 
then minimize them so that are on your desktop.
When you have found all relevant documents use the tiling feature, 
found under the Window menu in the IQ Browse window to arrange 
your open documents.      Make active the document into which you will 
be storing the links.    Choose the Hyperlink button, or alternatively, 
select the Edit menu, then Annotate, and then the Hyperlink item, or 
press CTRL-L on your keyboard.
Your cursor will change to a pen shape. Click on the place in the 
document where you want to create the link.    ISYS will display a list of 
all the other documents you currently have open.    Choose the 
filename to link to.

An alternative method makes use of ISYSs drag and drop capability by simply
clicking on the drag-drop tool, and dragging and dropping one document 
onto the other. 

Follow the steps above until you have your selected documents open.
Now choose the Drag/Drop button from the tool bar and drop one 
document into another.

You can also drag-drop from the document list and drop it onto a currently 
browsed document.    This is the fastest and easiest way to create a linkage, 
but of necessity only lets you link to the very top of that document, since the
document was not open and being browsed at the time of the link creation. 

When you navigate from link to link, Forward and Back buttons appear on the
browse window toolbar. These let you move forward and backward between 
documents in a hyperlink chain.

Viewing annotations



If an annotation is present, an appropriate symbol will appear in the body of 
the document.    To activate the annotation simply click on the symbol. 
The default embedded symbols are:

Text annotation
Graphic image link
Embedded query
Hyperlink to another document
Hyperactivity
If a Windows icon already exists for the program called by the 
hyperactivity, the programs icon will appear instead of the GO symbol.

Editing annotations
To edit an annotation, choose the appropriate Annotation button from the 
toolbar, or select the annotation type from the Edit menu.
Your cursor will change to a pen shape. When you move it over a embedded 
annotation icon, your cursor will change back to the arrow shape.
To move the annotation, click and drag the annotation symbol.    To edit or 
delete the annotation, click on the annotation symbol.    ISYS will open the 
annotation in Edit mode.



ISYS Query - File menu
Select database

Allows you to select another database to work with.
Filter Results

Displays the Filter window
Sort Results

Displays the Sort Options window
Clear

Clears the query results and closes any open documents in the IQ Browse 
window

Print
Prints the currently selected document.

Copy
Displays the dialog box for copying highlighted document to directory.

Hide
Removes the filename from the document list.

Tag
Tag a file for copying, printing etc.    Can also use Shift + Click.

Clear Tags
Clears tags from any tagged files.

Activate
Activates the selected documents application, and loads the document. 

Resource Registry
Displays the Resource Registry function.

Exit
Closes the ISYS Query window.



ISYS Query - Query menu
Makes a query using the query type last activated.
See Also:
Menu-assisted query
Command-based query
Query by concept
Saved query list
Plain English query



ISYS Query - Options menu
Synonyms

Displays the Synonyms window
Sections

Displays the Named Sections function
Printer

Displays the Print Options window
Toolbars

Dipslays the Toolbar selection item for Main and Browse windows.
Preferences

Displays the Preferences window
Document filenames

Displays the document filenames in the document list 
Document titles

Displays the document titles in the document list 
Context of hits

In the document list, displays the hits in the context they occur in the 
document



ISYS Query - Tools menu
Add to saved queries

Adds the last query made to the saved query list
Query in current results

Makes a hypertext query using the query type last used, on the documents 
in the document list only.

Query in previous results
Makes a hypertext query on the documents that were displayed in the 
document list for the query prior to the current query. A Query in current 
results must be made before this option can be used.

Menu-Assisted
Makes a query using the menu assisted method

Command-Based
Makes a query with the command based method

Query-By-Concept
Makes a query using the Concept tree

Saved Query List
Allows you to choose the query to run from a list of stored queries.

Paste Query from Clipboard - Query "<clipboard contents>"
The current contents of the Windows clipboard are used as the basis of a 
hypertext query. When there is something in the clipboard this menu shows 
as: 
Query "<clipboard contents>".

Plain English
Makes a query with the Plain English method

Extract
Extracts the document list to the clipboard or printer

Save Answer
Allows you to save the result of a query to disk

Load Answer
Allows you to load the results of a saved answer from disk



ISYS Query - Help menu
Displays this help file



IQ Browse - File menu
Activate App

Activates the selected document's application, with the document loaded 
into it

Copy File
Displays the Copy Document to File window, which enables you to copy the 
current document to another file

Print File
Send the entire document to the printer

Next File
Displays the next file in the document list

Previous File
Displays the previous file in the document list.

Exit
Quits IQ Browse



IQ Browse - Edit menu
Exact Search

The currently selected text is used for an exact search query.
Hypertext Search

The currently selected text is used for a Hypertext Query.
Annotate

Allows you to insert one of the annotation types (Text Note, Graphic Image 
Embedded Query, Hyperlink or Hyperactivity).

Annotation Directory
Directory for displaying and navigating any annotations created in the 
browsed document.

Send
E-mail the currently selected text to another user, using your e-mail 
application.

Print
The currently selected text is printed.

Fax
Currently selected text is sent to the configured fax interface.

Copy
The currently selected text is copied to the Clipboard.

Select All
For selecting all text in the currently browsed document.

Gather on Notepad
The currently selected text is gathered to the Notepad.



IQ Browse - Navigate menu
Next Annotation

Jump to the next annotation in the document
Previous Annotation

Jump to the previous annotation in the document
Next Hit

Jump to the next hit in the document
Previous Hit

Jump to the previous hit in the document.



IQ Browse - Window Menu
Cascade

Cascade currently browsed documents.
Tile Vertically

Tiles vertically currently browsed documents.
Tile Horizontally

Tiles horizontally currently browsed documents.



Resource Registry

To use the Resource Registry, choose the Resource Registry button or select 
the Resource Registry item from the File Menu.
To add resources to the registry, first create a folder, by choose the New 
button to display the New Register dialog box and enter a name for the 
folder.    Once your folder is created, resize the Resource Registry window so 
that it remains open for the drag and drop operation. 
Find the resource you require, click on the file name (you will see the drag 
and drop icon).    Position the icon over the folder in the Resource Registry 
and release the mouse button.    The file name will now appear in the window
on the right of the Registry window.    The button at the bottom right of the 
Registry window allows you to expand and collapse the resource description 
area. 
The right side of the Resource Registry window lists the contents of each 
folder's.    You will notice that there are buttons which allow you to View, 
Activate, Remove and Comment on each file.    The comment field allows for 
an entry of up to 35 characters. 
From within the Resource Registry you can view or activate a file, or drag- 
drop a file to another application.    To re-order a folder, just drag and drop it 
to where you want it to be.    If you want to replicate a pointer to a file into 
another folder, just drag and drop it to its new position.



Sections
By creating and using Sections ,    you are able to refine your queries to 
specific areas within a document.
To create a Section, select the Sections item from the Options Menu in the 
ISYS Query Window 
Choose the Add button to display the Section entry dialog box.
Sections are given arbitrary names; they do not have to match the 
paragraph label, but must be a single word.    Enter the name for the section, 
then move    to the box where you define the paragraph label at which the 
section starts, and then to the box where you define the paragraph label of 
the next section i.e. where the current section ends. 
In searches, if the word following the IN operator corresponds to a defined 
section name, ISYS does a special form of sectional search.    If the word 
following the IN operator does not correspond to a defined section name, 
ISYS assumes a labelled paragraph and proceeds normally. 
When conducting menu assisted queries, if you use the IN operator and 
sections have been defined, you can set a preference option so that the list 
of section names displays.



Save/Load Answer to disk
Once you have executed a search, if you wish you can save the list of 
retrieved documents to disk.
To do this, select the Save Answer to Disk option from the Tools menu.    ISYS 
will allow you to select the location for saving the file.    The Answer file is 
saved with an extension of ANS.    This file can be retrieved at a later date 
and will allow you to browse the documents along with the highlighted hits.    
If you open an ANS file that was generated from a different database, ISYS 
closes the currently opened database and opens the one the ANS file 
pertains to. 
Note that if you save a retrieved list to disk from a search carried out on a 
Chained database, if any of the documents have been added or changed in 
earlier databases in the chain, some of the references in your saved Answer 
file may be incorrect when you reload the answer file.    This is because for a 
chained database, the document numbers are notionally assigned for the 
duration of the chain, whereas document numbers remain constant in a 
regular or standalone database.




